Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 05, 2026 - 11:00 NZST
Scheduled
There may be a brief (1 min) pause accessing the S: and M: drives at the beginning and end of this maintenance but the SMB and NFS services will continue
Posted May 01, 2026 - 13:06 NZST
This scheduled maintenance affected: Managed Storage Service.